[packages/qt4] add the possibility of specifying and passing a path relative to ...
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Feb 2011 12:13:07 +0000 (12:13 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Feb 2011 12:13:07 +0000 (12:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25660 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/lib/qt4/files/qmake.mk

index f7f82e3..3415008 100644 (file)
@@ -36,8 +36,8 @@ define Build/Configure/Qmake
        STAGING_DIR="$(STAGING_DIR)" \
        qmake \
                -spec $(QMAKE_SPECFILE) \
-               -o $(PKG_BUILD_DIR)/Makefile \
-               $(PKG_BUILD_DIR)/$(1).pro
+               -o $(PKG_BUILD_DIR)/$(2)/Makefile \
+               $(PKG_BUILD_DIR)/$(2)/$(1).pro
 endef
 
 # we need to pass everything to $(MAKE) as well, as Makefiles may invoke qmake once again for creating further Makefiles