add horst package (olsr tool)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Nov 2007 17:34:00 +0000 (17:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Nov 2007 17:34:00 +0000 (17:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9478 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/horst/Makefile [new file with mode: 0644]

diff --git a/net/horst/Makefile b/net/horst/Makefile
new file mode 100644 (file)
index 0000000..a4b96f6
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 2007-10-31 23:30:20Z tetzlav $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=horst
+PKG_VERSION:=1.3pre
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://br1.einfach.org/horst/
+PKG_MD5SUM:=ceb1c8847be8e11db39df2fa74ac28f7
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/horst.git
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/horst
+       SECTION:=net
+       CATEGORY:=Network
+       DEPENDS:=+libncurses
+       MAINTAINER:=Bruno Randolf <br1@einfach.org>
+       TITLE:=Provides highly optimized radio scanning
+       URL:=http://br1.einfach.org/horst/
+endef
+
+define Package/horst/description
+       Provides highly optimized radio scanning.
+endef
+
+define Package/horst/install      
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/horst $(1)/usr/sbin/
+endef
+
+
+$(eval $(call BuildPackage,horst))