just build polipo, not all info and html docs, mark polipo.conf as a conffile
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Sep 2007 16:57:12 +0000 (16:57 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Sep 2007 16:57:12 +0000 (16:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8807 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/polipo/Makefile

index e279f46..6446dac 100644 (file)
@@ -36,15 +36,18 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
-               all
+               polipo
+endef
+
+define Package/polipo/conffiles
+/etc/polipo/polipo.conf
 endef
 
 define Package/polipo/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/var/cache/$(PKG_NAME)
-       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/config.sample $(1)/etc/$(PKG_NAME)/$(PKG_NAME).conf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/polipo $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/polipo
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/config.sample $(1)/etc/polipo/polipo.conf
 endef
 
 $(eval $(call BuildPackage,polipo))