usb-modeswitch: Fix a condition to compare default product id and switched product...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 02:59:10 +0000 (02:59 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 02:59:10 +0000 (02:59 +0000)
These default product id and switched product id are hex string variables, so this comparison operator should be '='.

Signed-off-by: Kentaro Matsuyama <kentaro.matsuyama@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28872 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/usb-modeswitch/Makefile
utils/usb-modeswitch/files/modeswitch.hotplug

index 62444f1..c033c72 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usb-modeswitch
 PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.draisberghof.de/usb_modeswitch
index 7f9ce94..8042451 100644 (file)
@@ -127,7 +127,7 @@ if [ "$ACTION" = add ]; then
                        [ -f "$usb_dir/idVendor" ] || usb_dir="${usb_dir%/*}"
                        while [ $switching_done -lt 1 -a $switching_tries -le 6 ]; do
                                $modeswitch -I -D -n -s 30 -c "${configs%% *}"
-                               if [ $(sanitize "$usb_dir/idProduct") -eq $uPid ]; then
+                               if [ $(sanitize "$usb_dir/idProduct") = $uPid ]; then
                                        log "switching seemingly failed"
                                else
                                        switching_done=1