[packages] libogg: don't ship dev shared lib symlink, cleanup
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2009 15:50:57 +0000 (15:50 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2009 15:50:57 +0000 (15:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17893 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libogg/Makefile

index 17324f8..8c94d9a 100644 (file)
@@ -10,14 +10,15 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=libogg
 PKG_VERSION:=1.1.4
 PKG_RELEASE:=2
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ogg/
-PKG_FIXUP:=libtool
 PKG_MD5SUM:=10200ec22543841d9d1c23e0aed4e5e9
 
-include $(INCLUDE_DIR)/package.mk
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
-PKG_INSTALL=1
+include $(INCLUDE_DIR)/package.mk
 
 define Package/libogg
   SECTION:=libs
@@ -47,7 +48,7 @@ endef
 
 define Package/libogg/install
        $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libogg))