net-tools: since we ship "slattach" it makes sense to enable SLIP support
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Mar 2013 11:18:24 +0000 (11:18 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Mar 2013 11:18:24 +0000 (11:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@36084 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/net-tools/Makefile
net/net-tools/patches/001-config.patch

index 0efc6f2..0748e05 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 - 2010 OpenWrt.org
+# Copyright (C) 2006 - 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-tools
 PKG_VERSION:=1.60
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.tazenda.demon.co.uk/phil/net-tools/
index 04760fb..673db17 100644 (file)
@@ -16,7 +16,7 @@
 +# HAVE_AFASH=0
 +HAVE_HWETHER=1
 +# HAVE_HWARC=0
-+# HAVE_HWSLIP=0
++HAVE_HWSLIP=1
 +HAVE_HWPPP=1
 +HAVE_HWTUNNEL=1
 +# HAVE_HWSTRIP=0
@@ -90,7 +90,7 @@
 +* 
 +bool 'UNIX protocol family' HAVE_AFUNIX y
 +bool 'INET (TCP/IP) protocol family' HAVE_AFINET y
-+bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 n
++bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 y
 +bool 'Novell IPX/SPX protocol family' HAVE_AFIPX n
 +bool 'Appletalk DDP protocol family' HAVE_AFATALK n
 +bool 'AX25 (packet radio) protocol family' HAVE_AFAX25 n
 +*
 +bool 'Ethernet (generic) support' HAVE_HWETHER y
 +bool 'ARCnet support' HAVE_HWARC n
-+bool 'SLIP (serial line) support' HAVE_HWSLIP n
++bool 'SLIP (serial line) support' HAVE_HWSLIP y
 +bool 'PPP (serial line) support' HAVE_HWPPP y
 +bool 'IPIP Tunnel support' HAVE_HWTUNNEL y
 +bool 'STRIP (Metricom radio) support' HAVE_HWSTRIP n
 + */
 +#define HAVE_HWETHER 1
 +#define HAVE_HWARC 0
-+#define HAVE_HWSLIP 0
++#define HAVE_HWSLIP 1
 +#define HAVE_HWPPP 1
 +#define HAVE_HWTUNNEL 1
 +#define HAVE_HWSTRIP 0