Remove gmp (moved)
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jun 2014 05:25:58 +0000 (05:25 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jun 2014 05:25:58 +0000 (05:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41066 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gmp/Makefile [deleted file]

diff --git a/libs/gmp/Makefile b/libs/gmp/Makefile
deleted file mode 100644 (file)
index 200818a..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gmp
-PKG_VERSION:=5.1.3
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gmplib.org/pub/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_MD5SUM:=a082867cbca5e898371a97bb27b31fea
-
-PKG_BUILD_PARALLEL:=1
-PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
-
-PKG_USE_MIPS16:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libgmp
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=GNU multiprecision arithmetic library
-  URL:=http://gmplib.org/
-endef
-
-define Package/libgmp/description
-       GMP is a free library for arbitrary precision arithmetic, operating on
-       signed integers, rational numbers, and floating point numbers.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-CONFIGURE_VARS += CC="$(TARGET_CROSS)gcc"
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-
-define Build/Compile
-       $(call Build/Compile/Default, \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CC="$(TARGET_CC)" \
-               all \
-       )
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gmp* $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgmp.{a,so*} $(1)/usr/lib/
-endef
-
-define Package/libgmp/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgmp.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libgmp))