packages: cups: do not try to package pdftops
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Feb 2013 13:54:53 +0000 (13:54 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Feb 2013 13:54:53 +0000 (13:54 +0000)
pdftops requires pdftops or gs, which neither is packaged in OpenWrt.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35698 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/cups/Makefile

index d5a85d9..550d00e 100644 (file)
@@ -394,6 +394,7 @@ define Build/Configure
                --with-cups-user="nobody" \
                --with-cups-group="nogroup" \
                --with-components="embedded" \
+               --with-pdftops="none" \
                --without-perl \
                --without-python \
                --without-php \
@@ -488,7 +489,7 @@ endef
 
 define Package/cups-filters/install
        $(INSTALL_DIR) $(1)/usr/lib/cups/filter
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups/filter/{bannertops,commandtoescpx,commandtopclx,imagetops,imagetoraster,pdftops,rastertoepson,rastertopwg,rastertohp,rastertoescpx,rastertopclx,rastertolabel,texttops} \
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups/filter/{bannertops,commandtoescpx,commandtopclx,imagetops,imagetoraster,rastertoepson,rastertopwg,rastertohp,rastertoescpx,rastertopclx,rastertolabel,texttops} \
                $(1)/usr/lib/cups/filter
        (cd $(1)/usr/lib/cups/filter; ln -sf rastertolabel rastertodymo;)
 endef