protobuf: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jun 2014 10:13:23 +0000 (10:13 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jun 2014 10:13:23 +0000 (10:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41199 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/protobuf/Makefile [deleted file]

diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
deleted file mode 100644 (file)
index 789c924..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=protobuf
-PKG_VERSION:=2.4.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://protobuf.googlecode.com/files
-PKG_MD5SUM:=ed436802019c9e1f40cc750eaf78f318
-
-PKG_BUILD_DEPENDS:=protobuf/host
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
-
-define Package/protobuf
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=A structured data encoding library
-  URL:=http://code.google.com/p/protobuf/
-  DEPENDS:=+zlib +libpthread +libstdcpp
-  MAINTAINER:=Obinou <obconseil@gmail.com>
-endef
-
-define Package/protobuf/description
- Protocol Buffers are a way of encoding structured data in an efficient
- yet extensible format. Google uses Protocol Buffers for almost all
- of its internal RPC protocols and file formats.
-endef
-
-CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR_HOST)/bin/protoc
-
-define Build/InstallDev
-       $(INSTALL_DIR) \
-               $(1)/usr/lib \
-               $(1)/usr/include
-
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/include/* \
-               $(1)/usr/include/
-
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/* \
-               $(1)/usr/lib/
-endef
-
-define Package/protobuf/install
-       $(INSTALL_DIR) \
-               $(1)/usr/lib
-
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libprotoc.so*  \
-               $(1)/usr/lib/
-
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-lite.so* \
-               $(1)/usr/lib/
-
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libprotobuf.so* \
-               $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,protobuf))
-$(eval $(call HostBuild))