[packages] make packages depending on uclibc++ depend on CXX_DEPENDS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Oct 2012 16:57:58 +0000 (16:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Oct 2012 16:57:58 +0000 (16:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34016 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/mysql/Makefile
libs/opal/Makefile
net/rrs/Makefile
net/yate/Makefile
utils/smartmontools/Makefile

index 06c2baf..40ad304 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=mysql
 PKG_VERSION:=5.1.53
@@ -29,7 +30,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libmysqlclient/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+uclibcxx +zlib
+  DEPENDS:=$(CXX_DEPENDS) +zlib
   TITLE:=MySQL client library
   URL:=http://dev.mysql.com/
 endef
index 380a8b2..19ca8c9 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=opal
 PKG_VERSION:=3.2.1
@@ -26,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libopal
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+ptlib +uclibcxx
+  DEPENDS:=+ptlib $(CXX_DEPENDS)
   TITLE:=Open Phone Abstraction Library
   URL:=http://www.opalvoip.org/
 endef
index e7d032c..efd54f4 100644 (file)
@@ -1,11 +1,12 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=rrs
 PKG_VERSION:=1.70
@@ -20,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/rrs/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+uclibcxx
+  DEPENDS:=$(CXX_DEPENDS)
   TITLE:=A reverse (connecting) remote shell
   URL:=http://www.cycom.se/dl/rrs/
 endef
index 5c74f29..27f2c28 100644 (file)
@@ -7,6 +7,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 RELEASEVER:=3.2.0
 
@@ -33,7 +34,7 @@ endef
 
 define Package/$(PKG_NAME)
   $(call Package/yate/Default)
-  DEPENDS:=+libpthread +uclibcxx
+  DEPENDS:=+libpthread $(CXX_DEPENDS)
   TITLE:=Yet Another Telphony Engine
   MENU:=1
 endef
index a69ab93..1fd75d6 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/smartmontools/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+uclibcxx
+  DEPENDS:=$(CXX_DEPENDS)
   TITLE:=S.M.A.R.T Monitoring
   URL:=http://smartmontools.sourceforge.net/
 endef