[packages] split ntpd package into ntpd, ntpdate and ntp-utils
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Apr 2008 23:32:52 +0000 (23:32 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Apr 2008 23:32:52 +0000 (23:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10918 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ntpd/Makefile

index 69f3598..3f693ff 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,17 +21,50 @@ PKG_BUILD_DEPENDS:=libelf
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/ntpd
+define Package/ntpd/Default
   SUBMENU:=Time Synchronization
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=full featured NTP server
-  DEPENDS:=+libreadline +libncurses
+  TITLE:=ISC ntp
   URL:=http://www.ntp.org/
 endef
 
+define Package/ntpd/Default/description
+       The ISC ntp suite is a collection of tools used to synchronize
+       the system clock with remote NTP time servers and run/montior
+       local NTP servers.
+endef
+
+define Package/ntpd
+  $(call Package/ntpd/Default)
+  DEPENDS:=+ntpdate
+  TITLE+= server
+endef
+
 define Package/ntpd/description
-       The full featured original ntpd
+       $(call Package/ntpd/Default/description)
+       This package contains the ntpd server.
+endef
+
+define Package/ntpdate
+  $(call Package/ntpd/Default)
+  TITLE+=date
+endef
+
+define Package/ntpdate/description
+       $(call Package/ntpd/Default/description)
+       This package contains ntpdate.
+endef
+
+define Package/ntp-utils
+  $(call Package/ntpd/Default)
+  DEPENDS:=+libreadline +libncurses
+  TITLE+= utilities
+endef
+
+define Package/ntp-utils/description
+       $(call Package/ntpd/Default/description)
+       This package contains ntpdc and ntpq.
 endef
 
 define Package/ntpd/conffiles
@@ -62,12 +95,9 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)"
 endef
 
-define Package/ntpd/install    
+define Package/ntpd/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd/ntpd $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpdate/ntpdate $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpdc/ntpdc $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpq/ntpq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/ntp.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
@@ -76,4 +106,17 @@ define Package/ntpd/install
        $(INSTALL_BIN) ./files/ntpd.hotplug $(1)/etc/hotplug.d/iface/20-ntpd
 endef
 
+define Package/ntpdate/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpdate/ntpdate $(1)/usr/sbin/
+endef
+
+define Package/ntp-utils/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpdc/ntpdc $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpq/ntpq $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,ntpd))
+$(eval $(call BuildPackage,ntpdate))
+$(eval $(call BuildPackage,ntp-utils))