packages/radsecproxy: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:15:31 +0000 (22:15 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:15:31 +0000 (22:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29052 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/radsecproxy/Makefile
net/radsecproxy/files/radsecproxy.init

index e1b0619..c7dd81a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-20211 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radsecproxy
 PKG_VERSION:=1.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
index 9576d96..b1b4f8e 100644 (file)
@@ -1,16 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=50
 
-DEFAULT=/etc/default/radsecproxy
-OPTIONS=""
-
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       /usr/sbin/radsecproxy $OPTIONS
+       service_start /usr/sbin/radsecproxy
 }
 
 stop() {
-       killall radsecproxy
+       service_stop /usr/sbin/radsecproxy
 }