uhub: link against librt when eglibc is enabled
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 Jun 2012 21:19:52 +0000 (21:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 Jun 2012 21:19:52 +0000 (21:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32543 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/uhub/Makefile

index 17c43da..3837be8 100644 (file)
@@ -21,7 +21,7 @@ define Package/uhub
   SUBMENU:=P2P
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent
+  DEPENDS:=+libevent +USE_EGLIBC:librt
   TITLE:=High performance ADC hub
   URL:=http://www.extatic.org/uhub/
 endef
@@ -32,6 +32,10 @@ define Package/uhub/description
         on high-end servers, or a small private hub on embedded hardware.
 endef
 
+ifdef CONFIG_USE_EGLIBC
+TARGET_LDFLAGS += -lrt
+endif
+
 define Package/uhub/install
        $(INSTALL_DIR) $(1)/usr/local/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhub $(1)/usr/local/bin/