updatedd: hotplug scripts should not be executable
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 20:00:13 +0000 (20:00 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 20:00:13 +0000 (20:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8633 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/updatedd/Makefile

index 145cbf4..12d119d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -121,7 +121,7 @@ define Package/updatedd/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/updatedd
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_BIN) ./files/updatedd.hotplug $(1)/etc/hotplug.d/iface/30-updatedd
+       $(INSTALL_DATA) ./files/updatedd.hotplug $(1)/etc/hotplug.d/iface/30-updatedd
 endef
 
 $(eval $(call BuildPackage,updatedd))