Port elinks to -ng
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 1 Aug 2006 18:06:50 +0000 (18:06 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 1 Aug 2006 18:06:50 +0000 (18:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4377 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/elinks/Makefile [new file with mode: 0644]
net/elinks/patches/01-missing_decl_for_off_t.patch [new file with mode: 0644]

diff --git a/net/elinks/Makefile b/net/elinks/Makefile
new file mode 100644 (file)
index 0000000..98f9890
--- /dev/null
@@ -0,0 +1,70 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elinks
+PKG_VERSION:=0.11.1
+PKG_RELEASE:=2
+PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
+
+PKG_SOURCE_URL:=http://elinks.or.cz/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/elinks
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl
+  TITLE:=A text based web browser
+  DESCRIPTION:=An advanced text based web browser
+  URL:=http://elinks.or.cz/
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,--enable-small\
+                       --enable-256-colors\
+                       --disable-backtrace\
+                       --disable-data\
+                       --disable-formhist\
+                       --disable-leds \
+                       --disable-mailcap\
+                       --disable-mouse \
+                       --disable-smb \
+                       --disable-uri-rewrite\
+                       --disable-xbel \
+                       --without-bzlib \
+                               --without-gpm \
+                       --without-idn \
+                       --without-gnutls \
+                       --without-libiconv \
+                       --without-lua \
+                       --with-openssl="$(STAGING_DIR)/usr" \
+                       --without-spidermonkey\
+                       --without-x\
+                       --without-zlib \
+                       --disable-ipv6 \, x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
+                       x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $$$${x}=yes && \
+)
+endef
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR)\
+               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld
+endef
+
+define Package/elinks/install
+       mkdir -p $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/elinks $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,elinks))
diff --git a/net/elinks/patches/01-missing_decl_for_off_t.patch b/net/elinks/patches/01-missing_decl_for_off_t.patch
new file mode 100644 (file)
index 0000000..4393e31
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ruN elinks-0.11.1-old/src/util/time.h elinks-0.11.1-new/src/util/time.h
+--- elinks-0.11.1-old/src/util/time.h  2006-01-29 14:10:39.000000000 +0100
++++ elinks-0.11.1-new/src/util/time.h  2006-03-27 23:09:08.000000000 +0200
+@@ -1,6 +1,7 @@
+ #ifndef EL__UTIL_TIME_H
+ #define EL__UTIL_TIME_H
++#include <sys/types.h>
+ #ifdef HAVE_SYS_TIME_H
+ #include <sys/time.h>
+ #endif