[package] add simplejson
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Aug 2011 12:08:38 +0000 (12:08 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Aug 2011 12:08:38 +0000 (12:08 +0000)
THe simplejson is a json encoder/decoder for python it is a lot faster
(close to 10x) than the json module that ships with python.

A special thanks to Jan Willies for the feedback on the distribute package.

Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28105 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/simplejson/Makefile [new file with mode: 0644]

diff --git a/lang/simplejson/Makefile b/lang/simplejson/Makefile
new file mode 100644 (file)
index 0000000..1af6761
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=simplejson
+PKG_VERSION:=2.1.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pypi.python.org/packages/source/s/simplejson/
+PKG_MD5SUM:=2f8351f6e6fe7ef25744805dfa56c0d5
+PKG_BUILD_DEPENDS:=python
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/simplejson
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Simple, fast, extensible JSON encoder/decoder for Python
+  URL:=http://simplejson.readthedocs.org/
+  DEPENDS:=+python +distribute
+endef
+
+define Package/simplejson/description
+  Simple, fast, extensible JSON encoder/decoder for Python
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+endef
+
+define Package/simplejson/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,simplejson))