[package] update shell-fm to 0.6 (#5407)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Jun 2009 20:26:16 +0000 (20:26 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Jun 2009 20:26:16 +0000 (20:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16572 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/shell-fm/Makefile
sound/shell-fm/patches/001-cross_compile.patch [deleted file]
sound/shell-fm/patches/002-wifcontinued.patch

index 9fc1277..3c47253 100644 (file)
@@ -8,25 +8,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shell-fm
-PKG_VERSION:=0.5
-PKG_RELEASE:=2
+PKG_VERSION:=0.6
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://nex.scrapping.cc/code/shell-fm/downloads/
-PKG_MD5SUM:=a257283b0f7e9173ee1073b88e57c5f6
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://github.com/jkramer/shell-fm.git
+PKG_SOURCE_VERSION:=df8bd30d280502c9ce62669e001d7de94d0dd5fe
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shell-fm
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libao +libmad
+  DEPENDS:=+libao +madplay +libpthread
   TITLE:=Console Based Last.FM Radio Player
   URL:=http://nex.scrapping.cc
 endef
 
 define Package/shell-fm/description
-       Shell.FM is a console based player for the streams provided 
+       Shell.FM is a console based player for the streams provided
        by Last.FM for the Linux platform. It's lightweight and easy to use.
 endef
 
@@ -42,11 +44,11 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -I./include/ $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               LDFLAGS="$(TARGET_LDFLAGS) -lmad -lao" \
+               LDFLAGS="$(TARGET_LDFLAGS) -lmad -lao -lpthread" \
                all install
 endef
 
-define Package/shell-fm/install        
+define Package/shell-fm/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/shell-fm $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc
diff --git a/sound/shell-fm/patches/001-cross_compile.patch b/sound/shell-fm/patches/001-cross_compile.patch
deleted file mode 100644 (file)
index 00e1953..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN shell-fm-0.5/source/Makefile shell-fm-0.5.new/source/Makefile
---- shell-fm-0.5/source/Makefile       2008-04-10 22:27:28.000000000 +0200
-+++ shell-fm-0.5.new/source/Makefile   2008-07-26 21:00:48.000000000 +0200
-@@ -9,7 +9,7 @@
- .PHONY: clean
- shell-fm      : $(OBJECT)
--      gcc -o $(BINARY) $(CFLAGS) $(OBJECT) $(shell pkg-config mad --libs) $(LDFLAGS)
-+      $(CC) -o $(BINARY) $(CFLAGS) $(OBJECT) $(shell pkg-config mad --libs) $(LDFLAGS)
- clean         :
-       rm -f $(OBJECT) $(BINARY)
index 7a12ce4..5c76fce 100644 (file)
@@ -1,7 +1,7 @@
---- shell-fm-0.5/source/main.c 2008-04-10 22:27:28.000000000 +0200
-+++ shell-fm-0.5.new/source/main.c     2008-07-27 13:50:43.000000000 +0200
-@@ -33,6 +33,10 @@
- #define PATH_MAX 4096
+--- a/source/main.c
++++ b/source/main.c
+@@ -44,6 +44,10 @@
+ #  endif
  #endif
  
 +#ifndef WIFCONTINUED