[package] make initscript of fastcgi-php to use /etc/rc.common
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 24 Oct 2010 13:20:30 +0000 (13:20 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 24 Oct 2010 13:20:30 +0000 (13:20 +0000)
currently the init.d script of fastcgi-php do not use the standard
rc.common methods. The attached patch fixes that.

Signed-off-by: Alexander Sulfrian <alexander@sulfrian.net>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23618 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/Makefile
lang/php5/files/php.init

index fd84461..ba3d992 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.3.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
index 0cb8509..2b8e4d9 100644 (file)
@@ -1,19 +1,16 @@
-#!/bin/sh
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2010 OpenWrt.org
+
+START=50
 
 export PHP_FCGI_CHILDREN=''
 PORT=1026
 BIN=/usr/bin/php-fcgi
 
-case $1 in
- start)
-  $BIN -b $PORT &
-  ;;
- stop)
-  kill `pidof php-fcgi`
-  ;;
- *)
-  echo "usage: $0 (start|stop)"
-  exit 1
-esac
+start() {
+       $BIN -b $PORT &
+}
 
-exit $?
+stop() {
+       kill `pidof php-fcgi`
+}