[packages] add xprop - an application used for settings X properties, patch by Lauri...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 May 2011 09:03:42 +0000 (09:03 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 May 2011 09:03:42 +0000 (09:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26981 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/xorg/app/xprop/Makefile [new file with mode: 0644]

diff --git a/Xorg/xorg/app/xprop/Makefile b/Xorg/xorg/app/xprop/Makefile
new file mode 100644 (file)
index 0000000..33dc46c
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xprop
+PKG_RELEASE:=1
+PKG_VERSION:=1.2.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/app/
+PKG_MD5SUM:=e6d0673a1e1e469f0a6220a6868fb94b
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/Xorg/$(PKG_NAME)-$(PKG_VERSION)/
+
+PKG_BUILD_DEPENDS:=xproto
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/xprop
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  DEPENDS:=+libX11
+  TITLE:=xprop
+  URL:=http://xorg.freedesktop.org/
+endef
+
+define Package/xprop/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/xprop \
+               $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,xprop))