packages/unfs3: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:16:05 +0000 (22:16 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:16:05 +0000 (22:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29068 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/unfs3/Makefile
net/unfs3/files/unfs3.init

index a0ab326..ddd6f71 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unfs3
 PKG_VERSION:=0.9.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
index 204c4fd..4a5965a 100644 (file)
@@ -1,17 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
 start() {
-       /usr/sbin/unfsd
+       service_start /usr/sbin/unfsd
 }
 
 stop() {
-       killall unfsd
-}
-
-restart() {
-       stop
-       sleep 1
-       start
+       service_stop /usr/sbin/unfsd
 }