openl2tp: Remove -Werror. Fixes compile on 2.6.36
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Oct 2010 18:58:57 +0000 (18:58 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Oct 2010 18:58:57 +0000 (18:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23427 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openl2tp/patches/001-makefile.patch

index 2f1f682..8fae8ef 100644 (file)
@@ -1,8 +1,12 @@
-Index: openl2tp-1.6/Makefile
-===================================================================
+---
+ Makefile     |   26 +++++++++++++-------------
+ cli/Makefile |    2 +-
+ usl/Makefile |    2 +-
+ 3 files changed, 15 insertions(+), 15 deletions(-)
+
 --- openl2tp-1.6.orig/Makefile
 +++ openl2tp-1.6/Makefile
-@@ -8,7 +8,7 @@
+@@ -8,7 +8,7 @@ L2TP_FEATURE_LAIC_SUPPORT=     y
  L2TP_FEATURE_LAOC_SUPPORT=    y
  L2TP_FEATURE_LNIC_SUPPORT=    y
  L2TP_FEATURE_LNOC_SUPPORT=    y
@@ -11,7 +15,7 @@ Index: openl2tp-1.6/Makefile
  #L2TP_FEATURE_LOCAL_STAT_FILE=        y
  
  # Define USE_DMALLOC to enable dmalloc memory debugging
-@@ -29,31 +29,31 @@
+@@ -29,31 +29,31 @@ L2TP_USE_ASYNC_RPC=        y
  # Build for UML environment?
  # UML_TARGET=         y
  
@@ -53,12 +57,37 @@ Index: openl2tp-1.6/Makefile
  
  # END CONFIGURABLE SETTINGS
  
-@@ -137,7 +137,7 @@
+@@ -135,9 +135,9 @@ endif
+ CPPFLAGS=             $(CPPFLAGS.l2tptest) $(CPPFLAGS-y)
  CFLAGS=                       -I. -Iusl -Icli -isystem $(KERNEL_BLDDIR)/include \
-                               -isystem $(KERNEL_SRCDIR)/include -MMD -Wall -Werror $(CPPFLAGS) $(CPPFLAGS.dmalloc) -DSYS_LIBDIR=$(SYS_LIBDIR)
+-                              -isystem $(KERNEL_SRCDIR)/include -MMD -Wall -Werror $(CPPFLAGS) $(CPPFLAGS.dmalloc) -DSYS_LIBDIR=$(SYS_LIBDIR)
++                              -isystem $(KERNEL_SRCDIR)/include -MMD -Wall $(CPPFLAGS) $(CPPFLAGS.dmalloc) -DSYS_LIBDIR=$(SYS_LIBDIR)
  LDFLAGS.l2tpd=                -Wl,-E -L. -Lusl -lusl -ldl $(LIBS.dmalloc) -lc
 -LDFLAGS.l2tpconfig=   -Lcli -lcli -lreadline $(LIBS.dmalloc) $(READLINE_LDFLAGS) -lc
 +LDFLAGS.l2tpconfig=   -Lcli -lcli -lreadline -lncurses $(LIBS.dmalloc) $(READLINE_LDFLAGS) -lc
  
  OPT_CFLAGS?=          -O
  
+--- openl2tp-1.6.orig/cli/Makefile
++++ openl2tp-1.6/cli/Makefile
+@@ -7,7 +7,7 @@ CLI_SRCS_TEST.o=       $(CLI_SRCS_TEST.c:%.c=%
+ LDFLAGS.cli_test=     -L.. -L. $(READLINE_LDFLAGS) -lcli -lusl -lreadline -lcurses -lc
+-CFLAGS=                       $(CFLAGS.optimize) -MMD -Wall -Werror -I.. $(READLINE_CFLAGS)
++CFLAGS=                       $(CFLAGS.optimize) -MMD -Wall -I.. $(READLINE_CFLAGS)
+ .PHONY:                       all test clean
+--- openl2tp-1.6.orig/usl/Makefile
++++ openl2tp-1.6/usl/Makefile
+@@ -14,7 +14,7 @@ LIBS.dmalloc=                -ldmalloc
+ endif
+ CPPFLAGS+=            $(CFLAGS.optimize) -g
+-CFLAGS=                       -I. -MMD -Wall -Werror $(CPPFLAGS) $(CPPFLAGS.dmalloc)
++CFLAGS=                       -I. -MMD -Wall $(CPPFLAGS) $(CPPFLAGS.dmalloc)
+ .PHONY:                       all test clean