boost: Allow sub-lib selection.
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jan 2010 14:54:11 +0000 (14:54 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jan 2010 14:54:11 +0000 (14:54 +0000)
This is not the optimum solution and it probably needs a rewrite using a Config.in file, but it's better than what we have now...

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18998 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/boost/Makefile

index 8b305d6..195262a 100644 (file)
@@ -29,24 +29,34 @@ define Package/boost
   URL:=http://www.boost.org/
 endef
 
+define Package/boost-serialization
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Boost-serialization library
+  DEPENDS:=+boost
+endef
+
+define Package/boost-regex
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Boost-regex library
+  DEPENDS:=+boost
+endef
+
 define Build/Configure
 endef
 
 # bjam does not support anything like DESTDIR
 CONFIGURE_PREFIX:=$(PKG_INSTALL_DIR)
 
-LIBRARIES:= \
-       serialization
-
 define Build/Compile
        ( cd $(PKG_BUILD_DIR) ; \
                echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <cflags>$(CFLAGS) <cxxflags>$(CXXFLAGS) <linkflags>$(LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
                bjam \
                        '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
                        --toolset=gcc --build-type=minimal --layout=system \
-                       $(foreach c, $(LIBRARIES), \
-                               --with-$(c) \
-                       ) \
+                       $(patsubst %,--with-regex,$(filter y m,$(CONFIG_PACKAGE_boost-regex))) \
+                       $(patsubst %,--with-serialization,$(filter y m,$(CONFIG_PACKAGE_boost-serialization))) \
                        $(CONFIGURE_ARGS) \
                        install \
        )
@@ -68,11 +78,6 @@ define Package/boost/install
        $(CP) $(PKG_INSTALL_DIR)/lib/*.so* $(1)/usr/lib/
 endef
 
-# TODO: Split libboost into several smaller packages
-
-#define Package/boost-serialization/install
-#    $(INSTALL_DIR) $(1)/usr/lib
-#      $(CP) $(PKG_INSTALL_DIR)/lib/*serialization*.so* $(1)/usr/lib/
-#endef
-
+$(eval $(call BuildPackage,boost-serialization))
+$(eval $(call BuildPackage,boost-regex))
 $(eval $(call BuildPackage,boost))