[packages/qt4] include linuxinput driver for keyboards by default
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Apr 2011 12:36:15 +0000 (12:36 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Apr 2011 12:36:15 +0000 (12:36 +0000)
why the heck can we build the linuxinput-keyboard driver as a plugin, but
the linuxinput-mouse driver can just be compiled in? Why does qt4 has
different drivers for mouse/keyboard using the linuxinput stack at all?

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26658 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/lib/qt4/Makefile

index f37d4b3..8c35c1f 100644 (file)
@@ -254,11 +254,6 @@ define Package/qt4-drivers-kbd/Default
   DEPENDS+=@QT4_WS_QWS
 endef
 
-define Package/qt4-drivers-kbd-linuxinput
-  $(call Package/qt4-drivers-kbd/Default)
-  TITLE+=linuxinput
-endef
-
 
 TARGET_INCDIRS+=$(STAGING_DIR)/include $(STAGING_DIR)/usr/include $(TOOLCHAIN_DIR)/include $(TOOLCHAIN_DIR)/usr/include
 TARGET_LIBDIRS+=$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib $(TOOLCHAIN_DIR)/lib $(TOOLCHAIN_DIR)/usr/lib
@@ -388,7 +383,7 @@ define Build/Configure
                        -no-kbd-qvfb \
                        -no-kbd-qnx \
                        -qt-kbd-tty \
-                       -plugin-kbd-linuxinput \
+                       -qt-kbd-linuxinput \
        )
 endef
 
@@ -735,15 +730,6 @@ define Package/qt4-drivers-gfx-linuxfb/install
 endef
 
 #  keyboard drivers
-define Package/qt4-drivers-kbd-linuxinput/install
-       $(INSTALL_DIR) \
-               $(1)/usr/lib/Qt/plugins/kbddrivers
-
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/kbddrivers/libqlinuxinputkbddriver.so \
-               $(1)/usr/lib/Qt/plugins/kbddrivers/
-endef
-
 
 
 
@@ -779,5 +765,3 @@ $(eval $(call BuildPackage,qt4-drivers-mouse-tslibmousedriver))
 
 $(eval $(call BuildPackage,qt4-drivers-gfx-directfb))
 $(eval $(call BuildPackage,qt4-drivers-gfx-linuxfb))
-
-$(eval $(call BuildPackage,qt4-drivers-kbd-linuxinput))