[packages_10.03.2] babel: merge r27933, r27987, r28119, r28239, r29512
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 19:37:06 +0000 (19:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 19:37:06 +0000 (19:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30080 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/babel/Makefile
net/babel/files/babeld.config
net/babel/files/babeld.init
net/babel/patches/001-fix-local_notify_route.patch [deleted file]

index 0eb8d2d..88bc6bc 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.1.0
-PKG_RELEASE:=3
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=0627cdc9a5ce77a032c4399c3fa64bd1
+PKG_MD5SUM:=05fc458d159b9b6fbf9c2f2f20eb8291
 
 include $(INCLUDE_DIR)/package.mk
 
index acc9e8a..d21a22b 100644 (file)
@@ -2,13 +2,14 @@ package babeld
 
 config general
        # option 'multicast_address' 'ff02:0:0:0:0:0:1:6'
-       # option 'port' '6697'
+       # option 'port' '6696'
        # option 'state_file' '/var/lib/babel-state'
        # option 'hello_interval' '4'
        # option 'wired_hello_interval' '20'
        # Enable  detection of idle networks.  This functonality is
        # experimental, don't use it unless you know what you are doing.
        ## option 'idle_hello_interval' '0'
+       # option 'diversity' '0,128'
        # option 'kernel_priority' '0'
        # Do not use this option unless you know what you are doing, as it can
        # cause persistent route flapping.
@@ -20,6 +21,8 @@ config general
        # option 'debug' '0'
        # Listen for connections from a front-end, e.g. on port 33123.
        ## option 'local_server' '33123'
+       # Keep unfeasible routes
+       ## option 'keep_unfeasible' 'false'
        # Use the given kernel routing table for routes inserted by babeld.
        ## option 'export_table' '0'
        # Export routes from the given kernel routing table.
@@ -41,9 +44,9 @@ config interface wlan
        # option 'split_horizon' 'auto'
        # The default is 96 for wired interfaces, and 256 for wireless ones
        ## option 'rxcost' '256'
-       # The  default  is  specified with the -h and -H command-line flags.
+       # The default is specified with the -h and -H command-line flags.
        ## option 'hello_interval' '4'
-       # This can be set to a  fairly  large  value,  unless significant
+       # This can be set to a fairly large  value,  unless significant
        # packet loss is expected.  The default is four times the hello
        # interval.
        ## option 'update_interval' '16'
index d6cd0d3..321f979 100755 (executable)
@@ -105,10 +105,12 @@ babel_config() {
        append_parm "$cfg" 'hello_interval' '-h'
        append_parm "$cfg" 'wired_hello_interval' '-H'
        append_parm "$cfg" 'idle_hello_interval' '-i'
+       append_parm "$cfg" 'diversity' '-z'
        append_parm "$cfg" 'kernel_priority' '-k'
        append_parm "$cfg" 'duplication_priority' '-A'
        append_parm "$cfg" 'debug' '-d'
        append_parm "$cfg" 'local_server' '-g'
+       append_parm "$cfg" 'keep_unfeasible' '-u'
        append_parm "$cfg" 'export_table' '-t'
        append_parm "$cfg" 'import_table' '-T'
        append_parm "$cfg" 'conf_file' '-c'
diff --git a/net/babel/patches/001-fix-local_notify_route.patch b/net/babel/patches/001-fix-local_notify_route.patch
deleted file mode 100644 (file)
index 0a52c5e..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Sat Mar  5 19:13:54 CET 2011  Gabriel Kerneis <kerneis@pps.jussieu.fr>
-  * Fix unique id in local_notify_route
-diff -rN -u old-babeld/local.c new-babeld/local.c
---- old-babeld/local.c 2011-03-14 14:37:03.000000000 +0100
-+++ new-babeld/local.c 2011-03-14 14:37:03.000000000 +0100
-@@ -197,11 +197,10 @@
-         return;
-     rc = snprintf(buf, 512,
--                  "%s route %s-%s-%lx prefix %s installed %s "
-+                  "%s route %s-%lx prefix %s installed %s "
-                   "id %s metric %d refmetric %d via %s if %s\n",
-                   local_kind(kind),
-                   format_prefix(route->src->prefix, route->src->plen),
--                  format_eui64(route->src->id),
-                   (unsigned long)route->neigh,
-                   format_prefix(route->src->prefix, route->src->plen),
-                   route->installed ? "yes" : "no",