fix libexif compile
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 Sep 2006 21:14:18 +0000 (21:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 Sep 2006 21:14:18 +0000 (21:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4881 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libexif/Makefile
libs/libexif/patches/100-no_doc.patch [new file with mode: 0644]

index db7ac11..03b6c82 100644 (file)
@@ -49,8 +49,10 @@ $(call Build/Configure/Default,--enable-shared \
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install)
+$(call Build/Compile/Default, \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install \
+)
 endef
 
 define Package/libexif/install
diff --git a/libs/libexif/patches/100-no_doc.patch b/libs/libexif/patches/100-no_doc.patch
new file mode 100644 (file)
index 0000000..9e232bf
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur libexif.old/Makefile.in libexif.dev/Makefile.in
+--- libexif.old/Makefile.in    2005-12-27 22:18:36.000000000 +0100
++++ libexif.dev/Makefile.in    2006-09-29 23:12:39.000000000 +0200
+@@ -213,7 +213,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-SUBDIRS = m4m po libexif test doc binary
++SUBDIRS = m4m po libexif test binary
+ @SHIP_BINARIES_TRUE@README_W32_XDIST = README-Win32.txt
+ EXTRA_DIST = @PACKAGE_TARNAME@.spec autogen.sh $(README_W32_XDIST)
+ ACLOCAL_AMFLAGS = -I m4m