Add radsecproxy (#2571)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Oct 2007 13:45:58 +0000 (13:45 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Oct 2007 13:45:58 +0000 (13:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9400 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/radsecproxy/Makefile [new file with mode: 0644]
net/radsecproxy/files/radsecproxy.init [new file with mode: 0644]

diff --git a/net/radsecproxy/Makefile b/net/radsecproxy/Makefile
new file mode 100644 (file)
index 0000000..f6e4e89
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=radsecproxy
+PKG_VERSION:=1.0p1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
+PKG_MD5SUM:=d1bdfd731342eda1242ba94703165fbe
+
+PKG_BUILD_DEPENDS:= libopenssl libpthread zlib
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/radsecproxy
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl +libpthread +zlib
+  TITLE:=radsecproxy
+  URL:=http://software.uninett.no/radsecproxy
+endef
+
+define Package/radsecproxy/description
+  A generic radius proxy for UDP/TLS (RadSec)
+endef
+
+CONFIGURE_ARGS+= \
+       --with-ssl="$(STAGING_DIR)/usr"
+
+#LIBS="-lz" \
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/radsecproxy/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/radsecproxy $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/
+       $(CP) $(PKG_INSTALL_DIR)/etc/radsecproxy.conf-example $(1)/etc/radsecproxy.conf
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/radsecproxy.init $(1)/etc/init.d/radsecproxy
+endef
+
+$(eval $(call BuildPackage,radsecproxy))
+
diff --git a/net/radsecproxy/files/radsecproxy.init b/net/radsecproxy/files/radsecproxy.init
new file mode 100644 (file)
index 0000000..f047275
--- /dev/null
@@ -0,0 +1,15 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+START=50
+
+DEFAULT=/etc/default/radsecproxy
+OPTIONS=""
+
+start() {
+       [ -f $DEFAULT ] && . $DEFAULT
+       /usr/sbin/radsecproxy $OPTIONS
+}
+
+stop() {
+       killall radsecproxy
+}