include: cmake: prevent inclusion of rpath in binaries
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Feb 2015 22:54:15 +0000 (22:54 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Feb 2015 22:54:15 +0000 (22:54 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44328 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/cmake.mk

index 6ab628e..862a6a9 100644 (file)
@@ -61,6 +61,7 @@ define Build/Configure/Default
                        -DCMAKE_INSTALL_PREFIX=/usr \
                        -DDL_LIBRARY=$(STAGING_DIR) \
                        -DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
+                       -DCMAKE_SKIP_RPATH=TRUE  \
                        $(CMAKE_OPTIONS) \
                $(CMAKE_SOURCE_DIR) \
        )