argp-standalone: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Jul 2014 21:49:53 +0000 (21:49 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Jul 2014 21:49:53 +0000 (21:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41807 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/argp-standalone/Makefile [deleted file]
libs/argp-standalone/patches/001-throw-in-funcdef.patch [deleted file]

diff --git a/libs/argp-standalone/Makefile b/libs/argp-standalone/Makefile
deleted file mode 100644 (file)
index 02e100d..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=argp-standalone
-PKG_VERSION:=1.3
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.lysator.liu.se/~nisse/misc/
-PKG_MD5SUM:=720704bac078d067111b32444e24ba69
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/argp-standalone
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Hierarchial argument parsing broken out from glibc
-  URL:=http://www.lysator.liu.se/~nisse/misc/
-endef
-
-define Package/argp-standalone/description
-  GNU libc hierarchial argument parsing library broken out from glibc.
-endef
-
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS) $(FPIC)"
-
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP)   $(PKG_BUILD_DIR)/argp.h \
-               $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP)   $(PKG_BUILD_DIR)/libargp.a \
-               $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,argp-standalone))
diff --git a/libs/argp-standalone/patches/001-throw-in-funcdef.patch b/libs/argp-standalone/patches/001-throw-in-funcdef.patch
deleted file mode 100644 (file)
index 4a90751..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# --- T2-COPYRIGHT-NOTE-BEGIN ---
-# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
-# 
-# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
-# Copyright (C) 2006 The T2 SDE Project
-# 
-# More information can be found in the files COPYING and README.
-# 
-# This patch file is dual-licensed. It is available under the license the
-# patched project is licensed under, as long as it is an OpenSource license
-# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
-# of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-# --- T2-COPYRIGHT-NOTE-END ---
-
-
-No __THROW in function implementation.
-       --jsaw
-
---- argp-standalone-1.4-test2/argp.h.orig      2006-01-06 02:29:59.000000000 +0100
-+++ argp-standalone-1.4-test2/argp.h   2006-01-06 02:41:10.000000000 +0100
-@@ -560,17 +560,17 @@
- # endif
- # ifndef ARGP_EI
--#  define ARGP_EI extern __inline__
-+#  define ARGP_EI extern inline
- # endif
- ARGP_EI void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__argp_usage (__const struct argp_state *__state)
- {
-   __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
- ARGP_EI int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__option_is_short (__const struct argp_option *__opt)
- {
-   if (__opt->flags & OPTION_DOC)
-     return 0;
-@@ -582,7 +582,7 @@
- }
- ARGP_EI int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__option_is_end (__const struct argp_option *__opt)
- {
-   return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }
---- argp-standalone-1.4-test2/argp-parse.c.orig        2006-01-06 02:47:48.000000000 +0100
-+++ argp-standalone-1.4-test2/argp-parse.c     2006-01-06 02:48:16.000000000 +0100
-@@ -1290,13 +1290,13 @@
- /* Defined here, in case a user is not inlining the definitions in
-  * argp.h */
- void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__argp_usage (__const struct argp_state *__state)
- {
-   __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
- int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__option_is_short (__const struct argp_option *__opt) 
- {
-   if (__opt->flags & OPTION_DOC)
-     return 0;
-@@ -1310,7 +1310,7 @@
- }
- int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__option_is_end (__const struct argp_option *__opt) 
- {
-   return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }