[packages] transmission: add run_daemon_as user to default config, build for embedded...
authorobsy <obsy@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Feb 2011 19:13:35 +0000 (19:13 +0000)
committerobsy <obsy@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Feb 2011 19:13:35 +0000 (19:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25392 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/transmission/Makefile
net/transmission/files/transmission.config
net/transmission/files/transmission.init

index c1e2377..d6fe79a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=2.20b4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
@@ -81,7 +81,8 @@ CONFIGURE_ARGS += \
        --enable-daemon \
        --enable-cli \
        --disable-gtk \
-       --enable-largefile
+       --enable-largefile \
+       --enable-lightweight
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
index bacaccc..36cbacc 100644 (file)
@@ -1,6 +1,7 @@
 config transmission
        option enabled 0
        option config_dir '/tmp/transmission'
+       option run_daemon_as_user root
        option alt_speed_down 50
        option alt_speed_enabled false
        option alt_speed_time_begin  540
index c3e8703..e790a7c 100644 (file)
@@ -72,7 +72,9 @@ start_service() {
 
        echo "\""invalid-key"\": false" >> $config_dir/settings.json
        echo "}" >> $config_dir/settings.json
-       
+
+       chown -R $run_as_usr $config_dir
+
        eval "$SSD -c $run_as_usr -q -b -x $BIN -S -- -g $config_dir"
 }