add quotes to TARGET_CC and TARGET_CROSS to help with distcc and ccache
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Aug 2006 03:28:27 +0000 (03:28 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Aug 2006 03:28:27 +0000 (03:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4430 3c298f89-4303-0410-b956-a3cf2f4a3e73

26 files changed:
libs/axtls/Makefile
libs/bzip2/Makefile
libs/libaudiofile/Makefile
libs/libelf/Makefile
libs/libiconv/Makefile
libs/libusb/Makefile
net/aiccu/Makefile
net/autossh/Makefile
net/dhcp6/Makefile
net/elhttp/Makefile
net/elinks/Makefile
net/fping/Makefile
net/httping/Makefile
net/oidentd/Makefile
net/pptpd/Makefile
net/tcpdump/Makefile
net/wpa_supplicant/Makefile
net/yafc/Makefile
utils/bc/Makefile
utils/gnupg/Makefile
utils/hdparm/Makefile
utils/heyu/Makefile
utils/lcd4linux/Makefile
utils/microcom/Makefile
utils/pciutils/Makefile
utils/strace/Makefile

index c740942..d4f5491 100644 (file)
@@ -44,7 +44,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                OPT_CFLAGS="$(TARGET_CFLAGS)" OPT_LDFLAGS=""
 endef
 
index bcb68af..0a46e4b 100644 (file)
@@ -35,7 +35,7 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                libbz2.a
 endef
index c9def02..689d40a 100644 (file)
@@ -62,7 +62,7 @@ define Build/Configure
                        $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --enable-static \
-                       --with-build-cc=$(HOSTCC) \
+                       --with-build-cc="$(HOSTCC)" \
        );
 endef
 
index ba16def..d644342 100644 (file)
@@ -72,7 +72,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld ARCH=$(ARCH) \
+               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" ARCH=$(ARCH) \
                instroot="$(PKG_INSTALL_DIR)" \
                all install
 endef
index 9bdafe5..49eade9 100644 (file)
@@ -35,7 +35,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
index a1fedbb..b8a882c 100644 (file)
@@ -66,7 +66,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld ARCH=$(ARCH) \
+               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" ARCH=$(ARCH) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
index 34e87c8..98d6ef2 100644 (file)
@@ -37,7 +37,7 @@ define Build/Compile
         rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" DEBUG=0
+               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" DEBUG=0
 endef
 
 define Package/aiccu/install
index e3905bf..391eca7 100644 (file)
@@ -38,7 +38,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"$(SSH)\\\"\" -D\"VER=\\\"$(PKG_VERSION)\\\"\"" \
+               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"$(SSH)\\\"\" -D\"VER=\\\"$(PKG_VERSION)\\\"\"" \
                BINDIR=/usr/bin MANDIR=/usr/man
 endef
 
index d6f0f99..a7f16bf 100755 (executable)
@@ -58,9 +58,9 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/server \
-               CC=$(TARGET_CC) STAGING_DIR=$(STAGING_DIR)
+               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/client \
-               CC=$(TARGET_CC) STAGING_DIR=$(STAGING_DIR)
+               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
 endef
 
 define Package/dhcp6-server/install
index 8c74f94..b9fcf62 100644 (file)
@@ -36,7 +36,7 @@ endef
 
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
-       $(MAKE) CC=$(TARGET_CC) CROSS=$(TARGET_CROSS) -C $(PKG_BUILD_DIR) \
+       $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" -C "$(PKG_BUILD_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
index 98f9890..519012e 100644 (file)
@@ -59,7 +59,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)\
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld
+               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld"
 endef
 
 define Package/elinks/install
index 7e14dc5..8f4902b 100644 (file)
@@ -40,9 +40,9 @@ $(call Build/Configure/Default)
 endef
 
 define Build/Compile   
-       $(MAKE) -j1 CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) clean $(PKG_NAME)
+       $(MAKE) -j1 CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) clean $(PKG_NAME)
        mv $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/$(PKG_NAME)4
-       $(MAKE) -j1 CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -DIPV6=1" -C $(PKG_BUILD_DIR) clean $(PKG_NAME)
+       $(MAKE) -j1 CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -DIPV6=1" -C $(PKG_BUILD_DIR) clean $(PKG_NAME)
        mv $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/$(PKG_NAME)6
 endef
 
index 0f30e96..f92015b 100644 (file)
@@ -34,7 +34,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) -f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) \
-               CC=$(TARGET_CC) STAGING_DIR=$(STAGING_DIR)
+               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
 endef
 
 define Package/httping/install 
index 41e90e3..3a0d0b2 100755 (executable)
@@ -40,7 +40,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
        $(STRIP) $(PKG_BUILD_DIR)/src/$(PKG_NAME)
 endef
 
index 8f07f0d..1766509 100755 (executable)
@@ -64,7 +64,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install" \
index 3776d63..017d33e 100644 (file)
@@ -36,7 +36,7 @@ endef
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-               BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+               BUILD_CC="$(TARGET_CC)" HOSTCC="$(HOSTCC)" \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
index 8e88632..678d7af 100755 (executable)
@@ -49,7 +49,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                KERNEL=$(LINUX_DIR) \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS=" -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
index ebdada4..4fa243d 100644 (file)
@@ -39,7 +39,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/yafc/install
index 3c36a22..8613c68 100644 (file)
@@ -47,7 +47,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/bc/install
index 8bf46c4..4ea1dc2 100644 (file)
@@ -78,7 +78,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/gnupg/install
index 34e0f03..36ced21 100644 (file)
@@ -38,7 +38,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/hdparm/install
index e93eca2..37d528d 100644 (file)
@@ -33,7 +33,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" \
                CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ"
 endef
 
index 8c072b3..5eb9e15 100644 (file)
@@ -66,7 +66,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" \
                CFLAGS="$(TARGET_CFLAGS) -Wall"
 endef
 
index c75cf67..ab21865 100644 (file)
@@ -43,7 +43,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) CC=$(TARGET_CC)
+       $(MAKE) -C $(PKG_BUILD_DIR) CC="$(TARGET_CC)"
 endef
 
 define Package/microcom/install
index fb3add2..7b12360 100644 (file)
@@ -38,7 +38,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
 endef
 
 define Package/pciutils/install
index 02a1b51..9c297fd 100644 (file)
@@ -62,7 +62,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/strace/install