override cflags (not honored by ./configure)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Oct 2006 17:13:24 +0000 (17:13 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Oct 2006 17:13:24 +0000 (17:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4910 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libnet-1.0.x/Makefile

index 2161e5e..9a12520 100644 (file)
@@ -55,7 +55,9 @@ define Build/Configure
 endef
 
 define Build/Compile
+       # pass CFLAGS again to override -O2 set by configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef