add workaround for the jamvm sdk compile - the sdk does not understand DEPENDS:=...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Apr 2007 15:13:56 +0000 (15:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Apr 2007 15:13:56 +0000 (15:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6863 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/jamvm/Makefile

index 23e5f21..7acd9fc 100644 (file)
@@ -48,11 +48,13 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) all
 endef
 
-define Package/jamvm/install   
+ifneq ($(ARCH),mips)
+  define Package/jamvm/install 
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/jamvm $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share/jamvm
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/lib/classes.zip $(1)/usr/share/jamvm/
-endef
+  endef
+endif
 
 $(eval $(call BuildPackage,jamvm))