freetype: moved to github
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Aug 2014 16:58:35 +0000 (16:58 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Aug 2014 16:58:35 +0000 (16:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42251 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/freetype/Makefile [deleted file]

diff --git a/libs/freetype/Makefile b/libs/freetype/Makefile
deleted file mode 100644 (file)
index 3a979bb..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=freetype
-PKG_VERSION:=2.4.8
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/freetype
-PKG_MD5SUM:=dbf2caca1d3afd410a29217a9809d397
-
-PKG_LICENSE:=FTL GPLv2 MIT ZLIB
-PKG_LICENSE_FILES:=docs/LICENSE.TXT docs/FTL.TXT docs/GPLv2.TXT src/bdf/README src/pcf/README src/gzip/zlib.h
-
-PKG_FIXUP:=autoreconf
-PKG_LIBTOOL_PATHS:=builds/unix
-
-include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libfreetype
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=A free, high-quality and portable font engine
-  URL:=http://www.freetype.org/
-  DEPENDS:=+zlib +libbz2
-endef
-
-define Package/libfreetype/description
- The FreeType project is a team of volunteers who develop free,
- portable and high-quality software solutions for digital typography.
- They specifically target embedded systems and focus on bringing small,
- efficient and ubiquitous products.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(2)/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
-
-       $(SED) \
-               's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
-                $(2)/bin/freetype-config
-endef
-
-
-define Package/libfreetype/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call HostBuild))
-$(eval $(call BuildPackage,libfreetype))