[package] hiawatha: update to 7.6
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Sep 2011 17:29:27 +0000 (17:29 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Sep 2011 17:29:27 +0000 (17:29 +0000)
Hi,

this patch updates hiawatha to 7.6.

Changelog since 7.3:

    PreventSQLi option rewritten.
    OldBrowser option added to URL toolkit.
    Improved mimetype configuration.
    Do-not-track HTTP header support.
    Password file entries can now be created with Wigwam.
    Small bugfixes and improvements.
    Bugfix: sent one byte too few for Range -XX.
    Bugfix: possible crash when using PreventSQLi.
    Bugfix: integer overflow in fetch_request() which could lead to a server crash.
    Connections per IP added to RequestLimitMask.
    NoExtensionAs made a per-host setting.
    Small bugfixes and improvements.
    Bugfix: usage of HideProxy caused Hiawatha to refuse new connections after ConnectionsTotal connections.
    Bugfix: memory leak in XSLT module.

Regards,

patch from Raphael Huck.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@28232 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/asterisk-chan-datacard/Makefile [new file with mode: 0644]
net/asterisk-chan-datacard/patches/001-cross_compile.patch [new file with mode: 0644]
net/hiawatha/Makefile

diff --git a/net/asterisk-chan-datacard/Makefile b/net/asterisk-chan-datacard/Makefile
new file mode 100644 (file)
index 0000000..e6ac7b6
--- /dev/null
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=asterisk18-chan-datacard
+PKG_REV:=185
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),$(PKG_NAME))-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://www.makhutov.org/svn/chan_datacard/trunk/
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/asterisk18-chan-datacard
+  SUBMENU:=asterisk18 (Complete Open Source PBX), v1.8.x
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://datacard.googlecode.com/
+  MAINTAINER:=Hans Zandbelt <hans.zandbelt@gmail.com>
+  DEPENDS:= +asterisk18 +libiconv-full
+  TITLE:=Huawei UMTS 3G datacards support
+endef
+
+define Package/asterisk18-chan-datacard/description
+       Asterisk channel driver for Huawei UMTS 3G datacards
+endef
+
+MAKE_VARS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) \
+               -I$(STAGING_DIR)/usr/include/asterisk-1.8/include \
+               -I$(STAGING_DIR)/usr/lib/libiconv-full/include"
+       LDFLAGS="$(TARGET_LDFLAGS) -liconv"
+
+define Build/Compile
+       $(call Build/Compile/Default)
+endef
+
+define Package/asterisk18-chan-datacard/conffiles
+/etc/asterisk/datacard.conf
+endef
+
+define Package/asterisk18-chan-datacard/install
+       $(INSTALL_DIR) $(1)/etc/asterisk
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/datacard.conf $(1)/etc/asterisk/
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/chan_datacard.so $(1)/usr/lib/asterisk/modules/
+endef
+
+$(eval $(call BuildPackage,asterisk18-chan-datacard))
diff --git a/net/asterisk-chan-datacard/patches/001-cross_compile.patch b/net/asterisk-chan-datacard/patches/001-cross_compile.patch
new file mode 100644 (file)
index 0000000..aedf81f
--- /dev/null
@@ -0,0 +1,20 @@
+Index: configure
+===================================================================
+--- a/configure        (rĂ©vision 185)
++++ b/configure        (copie de travail)
+@@ -29,13 +29,13 @@
+ Linux*)
+       DESTDIR="/usr/lib/asterisk/modules/"
+-      INCDIR="-I. -I/usr/include"
++      INCDIR="-I."
+       CFLAGS="-O2 -DICONV_CONST=\"\" -D__DEBUG__ -D__MANAGER__ -D__APP__"
+       LIBDIR=""
+       LIBS=""
+-      SOLINK="-shared -Xlinker -x"
++      SOLINK="-shared"
+ ;;
+ Darwin*)
+       DESTDIR="/opt/local/lib/asterisk/modules/"
index adc48f3..e1cbfa6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=7.3
+PKG_VERSION:=7.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=52fd6bf798c07298e12ff69b882f3d76
+PKG_MD5SUM:=45e7c3229a94d19abb5d92daa36c61d9
 
 PKG_INSTALL:=1
 
@@ -30,7 +30,7 @@ define Package/hiawatha
 endef
 
 define Package/hiawatha/description
-Hiawatha is an open source webserver with a focus on security.
+  Hiawatha is an open source webserver with a focus on security.
 endef
 
 CONFIGURE_ARGS+= \