AA: base-files: backport r36920
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Jun 2013 14:11:18 +0000 (14:11 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Jun 2013 14:11:18 +0000 (14:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36921 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/boot

index ee1deea..2152edd 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=118.1
+PKG_RELEASE:=118.2
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 1895f93..43837a8 100755 (executable)
@@ -95,13 +95,6 @@ start() {
                rootdev=$(awk 'BEGIN { RS=" "; FS="="; } $1 == "root" { print $2 }' < /proc/cmdline)
                [ -n "$rootdev" ] && ln -s "$rootdev" /dev/root
        }
-
-       # early sysctl to avoid networking races
-       if [ -d /proc/sys/net/ipv6/conf ]; then
-               for i in /proc/sys/net/ipv6/conf/*/accept_ra; do
-                       echo 0 > $i
-               done
-       fi
 }
 
 stop() {