libsamplerate: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Aug 2014 08:37:07 +0000 (08:37 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Aug 2014 08:37:07 +0000 (08:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41925 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libsamplerate/Makefile [deleted file]
libs/libsamplerate/patches/001-fix-m4-loop.patch [deleted file]

diff --git a/libs/libsamplerate/Makefile b/libs/libsamplerate/Makefile
deleted file mode 100644 (file)
index b31a649..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2007-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libsamplerate
-PKG_VERSION:=0.1.7
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.mega-nerd.com/SRC/
-PKG_MD5SUM:=ad093e60ec44f0a60de8e29983ddbc0f
-
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=autogen.sh
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libsamplerate
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=+libsndfile
-  TITLE:=Sample Rate Converter
-  URL:=http://www.mega-nerd.com/SRC/index.html
-endef
-
-define Package/libsamplerate/description
- Secret Rabbit Code (aka libsamplerate) is a Sample Rate
- Converter for audio.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --disable-fftw \
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
-
-define Package/libsamplerate/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libsamplerate))
diff --git a/libs/libsamplerate/patches/001-fix-m4-loop.patch b/libs/libsamplerate/patches/001-fix-m4-loop.patch
deleted file mode 100644 (file)
index e91499c..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -135,7 +135,6 @@ if test $ac_cv_c_byte_order = unknown ; 
-       fi
- )
--]
- if test $ac_cv_c_byte_order = big ; then
-       ac_cv_c_big_endian=1
-@@ -154,6 +153,7 @@ else
-       AC_MSG_WARN([[*****************************************************************]])
-       fi
-+]
- )# AC_C_FIND_ENDIAN