[package] php5: Fix build when simplexml is selected (#7758)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Mar 2011 21:22:32 +0000 (21:22 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Mar 2011 21:22:32 +0000 (21:22 +0000)
The build fails since the php module is statically disabled. This patch
adds the required magic.

This should also finally close #7758.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26341 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/Makefile

index 8022f63..d568901 100644 (file)
@@ -114,7 +114,6 @@ PKG_CONFIGURE_OPTS:= \
        --disable-short-tags \
        \
        --without-gettext \
-       --disable-simplexml \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
        --with-pcre-regex="$(STAGING_DIR)/usr" \
@@ -283,6 +282,12 @@ else
   PKG_CONFIGURE_OPTS+= --disable-session
 endif
 
+ifneq ($(CONFIG_PACKAGE_php5-mod-simplexml),)
+  PKG_CONFIGURE_OPTS+= --enable-simplexml=shared
+else
+  PKG_CONFIGURE_OPTS+= --disable-simplexml
+endif
+
 ifneq ($(CONFIG_PACKAGE_php5-mod-soap),)
   PKG_CONFIGURE_OPTS+= --enable-soap=shared
 else