collectd: add mod-memory (patch from #5591)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Oct 2009 03:55:36 +0000 (03:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Oct 2009 03:55:36 +0000 (03:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17847 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile
utils/collectd/patches/010-rrdtool-link-zlib.patch
utils/collectd/patches/100-rrdtool-add-rrasingle-option.patch

index 9b81a63..826f418 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.4.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
@@ -28,7 +28,7 @@ define Package/collectd/common_info
 endef
 
 define Package/collectd/description
-       collectd is a small daemon which collects system information periodically 
+       collectd is a small daemon which collects system information periodically
        and provides mechanismns to store the values in a variety of ways.
 endef
 
@@ -154,6 +154,12 @@ define Package/collectd-mod-load
         DEPENDS:=collectd
 endef
 
+define Package/collectd-mod-memory
+        $(call Package/collectd/common_info)
+        TITLE:=collectd - physical memory usage input plugin
+        DEPENDS:=collectd
+endef
+
 define Package/collectd-mod-netlink
         $(call Package/collectd/common_info)
         TITLE:=collectd - netlink input plugin (uses iproute2)
@@ -252,8 +258,8 @@ define Package/collectd-mod-wireless
 endef
 
 
-define Package/collectd/conffiles 
-/etc/collectd.conf 
+define Package/collectd/conffiles
+/etc/collectd.conf
 endef
 
 define Build/Configure
@@ -409,6 +415,11 @@ define Package/collectd-mod-logfile/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/collectd/logfile.so $(1)/usr/lib/collectd/
 endef
 
+define Package/collectd-mod-memory/install
+       $(INSTALL_DIR) $(1)/usr/lib/collectd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/collectd/memory.so $(1)/usr/lib/collectd/
+endef
+
 define Package/collectd-mod-netlink/install
        $(INSTALL_DIR) $(1)/usr/lib/collectd
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/collectd/netlink.so $(1)/usr/lib/collectd/
@@ -521,6 +532,7 @@ $(eval $(call BuildPackage,collectd-mod-iptables))
 $(eval $(call BuildPackage,collectd-mod-irq))
 $(eval $(call BuildPackage,collectd-mod-load))
 $(eval $(call BuildPackage,collectd-mod-logfile))
+$(eval $(call BuildPackage,collectd-mod-memory))
 $(eval $(call BuildPackage,collectd-mod-netlink))
 $(eval $(call BuildPackage,collectd-mod-network))
 $(eval $(call BuildPackage,collectd-mod-nginx))
index aa3b0b6..b10af46 100644 (file)
@@ -1,8 +1,6 @@
-Index: collectd-4.4.3/configure
-===================================================================
---- collectd-4.4.3.orig/configure      2008-09-08 11:14:03.000000000 +0200
-+++ collectd-4.4.3/configure   2008-09-08 11:14:21.000000000 +0200
-@@ -31446,7 +31446,7 @@
+--- a/configure
++++ b/configure
+@@ -31446,7 +31446,7 @@ if test "${with_rrdtool+set}" = set; the
    withval=$with_rrdtool;      if test "x$withval" != "xno" && test "x$withval" != "xyes"
        then
                librrd_cflags="-I$withval/include"
index 23c7861..dd0bb42 100644 (file)
@@ -1,8 +1,6 @@
-Index: collectd-4.4.2/src/rrdtool.c
-===================================================================
---- collectd-4.4.2.orig/src/rrdtool.c  2008-07-17 19:30:00.000000000 +0200
-+++ collectd-4.4.2/src/rrdtool.c       2008-07-17 19:30:44.000000000 +0200
-@@ -87,6 +87,7 @@
+--- a/src/rrdtool.c
++++ b/src/rrdtool.c
+@@ -87,6 +87,7 @@ static const char *config_keys[] =
        "HeartBeat",
        "RRARows",
        "RRATimespan",
@@ -10,7 +8,7 @@ Index: collectd-4.4.2/src/rrdtool.c
        "XFF"
  };
  static int config_keys_num = STATIC_ARRAY_SIZE (config_keys);
-@@ -1077,6 +1078,14 @@
+@@ -1077,6 +1078,14 @@ static int rrd_config (const char *key, 
                }
                xff = tmp;
        }