work around wrong permissions in the arpwatch tarball - fixes avr32 compile issues
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 16:31:11 +0000 (16:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 16:31:11 +0000 (16:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12908 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/arpwatch/Makefile

index b63f5f8..4ca72b5 100644 (file)
@@ -35,6 +35,11 @@ define Package/arpwatch/conffiles
 /etc/arpwatch/arp.dat
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARPDIR=/etc/arpwatch \