[Packages] admin/htop: Update to 0.7 (#3415)
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 7 May 2008 18:58:13 +0000 (18:58 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 7 May 2008 18:58:13 +0000 (18:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11060 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/htop/Makefile
admin/htop/patches/001_remove_proc_check.patch

index 1bda989..a6743af 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,34 +9,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htop
-PKG_VERSION:=0.6.6
+PKG_VERSION:=0.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/htop
-PKG_MD5SUM:=12c8e6e97bd50a4e0a4730d23675fc7b
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=4afc961fa709167e1b434682897991f9
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/htop
   SECTION:=admin
   CATEGORY:=Administration
-  TITLE:=process viewer
+  TITLE:=Interactive processes viewer
   DEPENDS:=+libncurses
   URL:=http://htop.sourceforge.net/
 endef
 
 define Package/htop/description
-       An interactive process viewer with colors tree mode and other features.
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
+ Htop is an ncursed-based process viewer similar to top, but
+ it allows to scroll the list vertically and horizontally to
+ see all processes and their full command lines. 
 endef
 
 define Package/htop/install    
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,htop))
index 664b29a..6400214 100644 (file)
@@ -1,12 +1,11 @@
-Index: htop-0.6.6/configure
+Index: htop-0.7/configure
 ===================================================================
---- htop-0.6.6.orig/configure  2007-09-20 10:45:31.000000000 -0500
-+++ htop-0.6.6/configure       2007-09-20 10:45:31.000000000 -0500
-@@ -6207,62 +6207,6 @@
+--- htop-0.7.orig/configure    2008-05-07 20:52:47.000000000 +0200
++++ htop-0.7/configure 2008-05-07 20:52:47.000000000 +0200
+@@ -5844,61 +5844,6 @@
  
  fi
  
--
 -as_ac_File=`echo "ac_cv_file_$PROCDIR/stat" | $as_tr_sh`
 -{ echo "$as_me:$LINENO: checking for $PROCDIR/stat" >&5
 -echo $ECHO_N "checking for $PROCDIR/stat... $ECHO_C" >&6; }