[packages] perl: COrrect installation of prove binary for test hasrness
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Jan 2013 15:20:19 +0000 (15:20 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Jan 2013 15:20:19 +0000 (15:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35197 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/perl/perlbase.mk

index 595cb1b..b6f5f78 100644 (file)
@@ -1466,8 +1466,9 @@ TITLE:=Test perl module
 endef
 
 define Package/perlbase-test/install
+$(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prove $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prove $(1)/usr/bin
        $(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
 endef