add pls handler to mpc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Feb 2008 01:48:25 +0000 (01:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Feb 2008 01:48:25 +0000 (01:48 +0000)
this patch adds a little script to the mpc package. pls handler takes
a .pls file as argument - mpd is then playing the stream.

cheers
michu

Signed-off-by: Michael Vogt <michu at neophob.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10352 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mpc/Makefile
sound/mpc/files/pls-handler.sh [new file with mode: 0644]

index ae3fabf..22da22a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
 PKG_VERSION:=0.12.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
@@ -51,6 +51,7 @@ endef
 define Package/mpc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/mpc $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/pls-handler.sh $(1)/usr/bin
 endef
 
 $(eval $(call BuildPackage,mpc))
diff --git a/sound/mpc/files/pls-handler.sh b/sound/mpc/files/pls-handler.sh
new file mode 100644 (file)
index 0000000..9394417
--- /dev/null
@@ -0,0 +1,5 @@
+#!/usr/bin/env sh
+echo parameter: file.pls
+mpc clear
+grep '^File[0-9]*' $1 | sed -e 's/^File[0-9]*=//' | mpc add
+mpc play
\ No newline at end of file