utils/psmisc: add psmisc package
authoracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Jul 2010 17:13:30 +0000 (17:13 +0000)
committeracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Jul 2010 17:13:30 +0000 (17:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22072 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/psmisc/Makefile [new file with mode: 0644]

diff --git a/utils/psmisc/Makefile b/utils/psmisc/Makefile
new file mode 100644 (file)
index 0000000..3ad7c02
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=psmisc
+PKG_VERSION:=22.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://psmisc.sourceforge.net
+PKG_MD5SUM:=b5d32aa285b75c59dee96d3ea26a4881
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/psmisc
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libncurses
+  TITLE:=proc utilities
+  URL:=http://sourceforge.net/projects/psmisc/
+endef
+
+define Package/psmisc/description
+ psmisc is a set of additional small useful utilities that use
+ the proc filesystem: fuser, killall, pstree, and pidof
+endef
+
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CPPFLAGS="$(TARGET_CPPFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS)" \
+
+define Package/psmisc/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fuser $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/killall $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pstree $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,psmisc))