empcd: pass our CFLAGS and LDFLAGS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:47 +0000 (00:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:47 +0000 (00:56 +0000)
The package Makefile already provides some CFLAGS and LDFLAGS but
we want to use ours.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39804 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/empcd/Makefile

index 8b0c15d..f5b0cd7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=empcd
 PKG_VERSION:=2008.02.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://unfix.org/projects/empcd
@@ -37,11 +37,12 @@ endef
 define Build/Compile
        $(call Build/Compile/Default,\
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               $(TARGET_CONFIGURE_OPTS) \
                all \
        )
 endef
 
-define Package/empcd/install   
+define Package/empcd/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/empcd $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc