luabitop: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jun 2014 08:42:32 +0000 (08:42 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jun 2014 08:42:32 +0000 (08:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41099 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/luabitop/Makefile [deleted file]

diff --git a/lang/luabitop/Makefile b/lang/luabitop/Makefile
deleted file mode 100644 (file)
index 33727f5..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=luabitop
-PKG_VERSION:=1.0.2
-PKG_RELEASE:=1
-
-_BASENAME:=LuaBitOp
-
-PKG_SOURCE:=$(_BASENAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://bitop.luajit.org/download/
-PKG_MD5SUM:=d0c1080fe0c844e8477279668e2d0d06
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(_BASENAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/luabitop
-  SUBMENU:=Lua
-  SECTION:=lang
-  CATEGORY:=Languages
-  TITLE:=luabitop
-  URL:=http://bitop.luajit.org/
-  DEPENDS:=+lua
-endef
-
-define Package/luabitop/description
-Lua BitOp is a C extension module for Lua 5.1/5.2 which adds bitwise operations on numbers.
-endef
-
-define Build/Configure
-endef
-
-
-TARGET_CFLAGS += $(FPIC) -DLUA_USE_LINUX -DLUA_NUMBER_DOUBLE
-
-define Build/Compile
-       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_CPPFLAGS) -std=gnu99 $(FPIC) -DLUA_USE_LINUX -shared -o $(PKG_BUILD_DIR)/bit.so $(PKG_BUILD_DIR)/bit.c
-endef
-
-define Package/luabitop/install
-       $(INSTALL_DIR) $(1)/usr/lib/lua
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bit.so $(1)/usr/lib/lua
-endef
-
-$(eval $(call BuildPackage,luabitop))