Update mosquitto to 0.15
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Jul 2012 11:04:03 +0000 (11:04 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Jul 2012 11:04:03 +0000 (11:04 +0000)
Includes support for the luci-app-mosquitto package, if installed.

Signed-off-by: Karl Palsson <karlp@remake.is>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32564 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/mosquitto/Makefile
net/mosquitto/files/mosquitto.init

index 26d38aa..56f2a64 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mosquitto
-PKG_VERSION:=0.14.4
+PKG_VERSION:=0.15
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mosquitto.org/files/source/
-PKG_MD5SUM:=88750338c2096671c01cf7e461d5c06d
+PKG_MD5SUM:=7ae0ac38f1f379578ab5530e5dc7269e
 
 include $(INCLUDE_DIR)/package.mk
 
index b6ce617..aafa105 100755 (executable)
@@ -1,16 +1,27 @@
 #!/bin/sh /etc/rc.common
 # Basic init script for mosquitto
 # April 2012, OpenWrt.org
+# Provides support for the luci-app-mosquitto package, if installed
 
 START=80
 APP=`which mosquitto`
+USE_UCI_CONFIG=$(uci -q get mosquitto.owrt.use_uci)
+if [ $? -eq 1 ]; then
+    USE_UCI_CONFIG=0
+fi
 
 SERVICE_DAEMONIZE=1
 SERVICE_WRITE_PID=1
 
 start() {
         user_exists mosquitto 200 || user_add mosquitto 200
-        service_start $APP -c /etc/mosquitto/mosquitto.conf
+        if [ "$USE_UCI_CONFIG" -eq 1 ]; then
+            CONF=/tmp/mosquitto.converted.$$.conf
+            mosquitto.uci.convert -f $CONF
+        else
+            CONF=/etc/mosquitto/mosquitto.conf
+        fi
+        service_start $APP -c $CONF
 }
 
 stop() {