this patch fixes a build error described in ticket #6702.
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 04:51:10 +0000 (04:51 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 04:51:10 +0000 (04:51 +0000)
-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19770 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/strace/Makefile

index 4caa2e4..5b096d2 100644 (file)
@@ -40,12 +40,17 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
 system calls a program makes while it is running.
 endef
 
+# needed when compiling against Linux 2.4
 CONFIGURE_VARS += \
        ac_cv_header_linux_netlink_h=yes
 
+# needed when compiling with an external toolchain
 TARGET_CFLAGS += \
        -I$(LINUX_DIR)/include
 
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
+
 define Package/strace/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/