elfutils: fix build with CONFIG_NLS_FULL (#12740)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Jan 2013 10:15:44 +0000 (10:15 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Jan 2013 10:15:44 +0000 (10:15 +0000)
Thanks to mva for providing logs.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35166 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/elfutils/Makefile

index 7dcc2c7..4f2ffa5 100644 (file)
@@ -38,6 +38,10 @@ define Package/libelf1
   TITLE+= (libelf)
 endef
 
+ifeq ($(CONFIG_BUILD_NLS),y)
+TARGET_LDFLAGS += "-lintl"
+endif
+
 ifdef CONFIG_USE_UCLIBC
 CONFIGURE_VARS += \
        LIBS="-largp"