[packages] git: get rid of XDL_FAST_HASH, it does NOT work on big-endian systems,
authortripolar <tripolar@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jul 2013 14:17:11 +0000 (14:17 +0000)
committertripolar <tripolar@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jul 2013 14:17:11 +0000 (14:17 +0000)
and uname is no reliable way to determine which arch will run git
closes #13611

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37239 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/git/Makefile
net/git/patches/200-disable_fasthash.patch [new file with mode: 0644]

index f89944f..bb83e73 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
 PKG_VERSION:=1.8.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://git-core.googlecode.com/files/
diff --git a/net/git/patches/200-disable_fasthash.patch b/net/git/patches/200-disable_fasthash.patch
new file mode 100644 (file)
index 0000000..cd5d603
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/config.mak.uname b/config.mak.uname
+index d78fd3d..43f5c5e 100644
+--- a/config.mak.uname
++++ b/config.mak.uname
+@@ -17,9 +17,6 @@ endif
+ # because maintaining the nesting to match is a pain.  If
+ # we had "elif" things would have been much nicer...
+-ifeq ($(uname_M),x86_64)
+-      XDL_FAST_HASH = YesPlease
+-endif
+ ifeq ($(uname_S),OSF1)
+       # Need this for u_short definitions et al
+       BASIC_CFLAGS += -D_OSF_SOURCE