[packages] lft: update to 3.32
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 May 2011 01:02:35 +0000 (01:02 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 May 2011 01:02:35 +0000 (01:02 +0000)
 * add whob package
 * disable install target strip'ping
 * remove obsolete pcap cflags patch
 * use PKG_INSTALL & CONFIGURE_ARGS

git-svn-id: svn://svn.openwrt.org/openwrt/packages@27016 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/lft/Makefile
net/lft/patches/001-add_pcap_includes.patch [deleted file]
net/lft/patches/001-no_strip.patch [new file with mode: 0644]

index 5dd156d..1c946b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lft
-PKG_VERSION:=3.1
+PKG_VERSION:=3.32
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pwhois.org/get
-PKG_MD5SUM:=70e69706e7600f34c0dfb54e2ee5eb01
+PKG_MD5SUM:=5f09c9ad2475cb237b8277a2d69c569c
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/lft
+define Package/lft/Default
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libpcap
@@ -25,7 +27,7 @@ define Package/lft
   URL:=http://pwhois.org/lft
 endef
 
-define Package/lft/description
+define Package/lft/Default/description
        LFT, short for Layer Four Traceroute, is a sort of 'traceroute' that
        often works much faster (than the commonly-used Van Jacobson method)
        and goes through many configurations of packet-filters (firewalls).
@@ -34,19 +36,36 @@ define Package/lft/description
        netblock name lookups, et al.
 endef
 
-define Build/Configure 
-       $(call Build/Configure/Default, \
-               --with-pcap="$(STAGING_DIR)/usr" \
-       )
+define Package/lft
+  $(call Package/lft/Default)
+endef
+
+define Package/lft/description
+       $(call Package/lft/Default/description)
+       This package contains the lft 'traceroute' program.
+endef
+
+define Package/whob
+  $(call Package/lft/Default)
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)
+define Package/whob/description
+       $(call Package/lft/Default/description)
+       This package contains the whob 'whois' program.
+endef
+
+CONFIGURE_ARGS += \
+       --with-pcap="$(STAGING_DIR)/usr"
+
+define Package/lft/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lft $(1)/usr/bin/
 endef
 
-define Package/lft/install     
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lft $(1)/usr/sbin/
+define Package/whob/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/whob $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,lft))
+$(eval $(call BuildPackage,whob))
diff --git a/net/lft/patches/001-add_pcap_includes.patch b/net/lft/patches/001-add_pcap_includes.patch
deleted file mode 100644 (file)
index 03e5f3f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -46,7 +46,7 @@
-       $(CC) -o lft $(OBJS) $(LDFLAGS) $(LIBS)
- whob: whois.o
--      $(CC) -o whob whois.c -DSTANDALONE $(LDFLAGS) $(LIBS)
-+      $(CC) -o whob whois.c -DSTANDALONE -I$(STAGING_DIR)/usr/include $(LDFLAGS) $(LIBS)
- install: lft lft.8 whob whob.8
-       @echo "Installing LFT and WhoB"
diff --git a/net/lft/patches/001-no_strip.patch b/net/lft/patches/001-no_strip.patch
new file mode 100644 (file)
index 0000000..f58fbda
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -50,8 +50,6 @@ whob: whois.o
+ install: lft lft.8 whob whob.8
+       @echo "LFT and WhoB"
+-      @echo "  \_Stripping binaries"
+-      @strip lft whob
+       @echo "  \_Copying files to their intended destinations"
+       @test -d $(DESTDIR)$(bindir)/. || $(MKDIR) $(DESTDIR)$(bindir)
+       $(INSTALL) lft $(DESTDIR)$(bindir)/lft